in hardware

HOWTO Installation of OpenWRT on a WGT634U usb router Part 2

OK, we now have to configure the network. The goal is to be able to connect to our access point, where we’ll get information to connect to our “sound server” (I call it like that because I’ve still not decided between using mpd+mpc+samba or some more direct access like the use of esd).

We’ll set the wifi interface as a client for a remote access point. We’ll keep the WAN interface with a static ip (here, 192.168.1.1)

Please note, that changing the configuration will make the remote network access as previously used unusable. The only secure access is still through the serial console.

First, edit the file /etc/config/network:

config switch eth0
option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"
[...] # localhost config here
[...]
config interface wan
option ifname "eth0.1"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
[...]
config interface lan
option type bridge
option ifname "eth0.0"
option proto dhcp

And then the file /etc/config/wireless:

config wifi-device wifi0
option type atheros
option channel 8
option disabled 0
[...]
config wifi-iface
option device wifi0
option network lan
option mode sta
option ssid YOUR_SSID
option encryption none
option hidden 0

If your access point has some encryption, like WEP, do this instead of the wifi-iface block:
config wifi-iface
option device wifi0
option network lan
option mode sta
option ssid YOUR_SSID
option encryption wep
option key 1234567899
option hidden 0

You can take a look at the different available options on this documentation. If all is well, you should have an ip address on your br-lan interface (your WHGT634U hub port is bridged with the wifi interface).

Next part will be the most interesting :-) I think I’ll try all the different methods to implement an automatic player daemon. Direct methods, and indirect methods, using a share fielsystem like CIFS.

Reference

Jkx@Home’s article explaining another use of WGT634U

FacebooktwitterredditpinterestlinkedinmailNo tags for this post.

Write a Comment

Comment